*/*: Specify EAPI=0 explicitly, to ease greps
[gentoo.git] / x11-libs / libast / libast-0.7.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 DESCRIPTION="LIBrary of Assorted Spiffy Things"
7 HOMEPAGE="http://www.eterm.org/download/"
8 SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
13 IUSE="imlib cpu_flags_x86_mmx pcre"
14
15 RDEPEND="!sci-astronomy/ast
16         x11-libs/libXt
17         x11-proto/xproto
18         x11-libs/libICE
19         x11-libs/libSM
20         x11-libs/libX11
21         =media-libs/freetype-2*
22         imlib? ( media-libs/imlib2 )
23         pcre? ( dev-libs/libpcre )"
24 DEPEND="${RDEPEND}"
25
26 src_compile() {
27         local myregexp="posix"
28         use pcre && myregexp="pcre"
29         econf \
30                 $(use_with imlib) \
31                 $(use_enable cpu_flags_x86_mmx mmx) \
32                 --with-regexp=${myregexp} \
33                 || die
34         emake || die
35 }
36
37 src_install() {
38         make DESTDIR="${D}" install || die
39         dodoc README DESIGN ChangeLog
40 }