*/*: [QA] Remove redundant `|| die` guards
[gentoo.git] / x11-libs / gtkglarea / gtkglarea-2.1.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 GCONF_DEBUG="no"
6
7 inherit gnome2
8
9 DESCRIPTION="OpenGL canvas and context provider for GTK+"
10 HOMEPAGE="https://www.mono-project.com/archived/gtkglarea/"
11
12 LICENSE="LGPL-2+ GPL-2+" # examples are GPL-2+, library is LGPL-2+
13 SLOT="2"
14 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux"
15 IUSE="examples"
16
17 RDEPEND="
18         >=x11-libs/gtk+-2.22:2
19         virtual/opengl
20 "
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig
23 "
24
25 src_prepare() {
26         # Do not build examples
27         sed -e "s:\(SUBDIRS.*\)examples:\1:" \
28                 -i Makefile.am Makefile.in || die "sed 1 failed"
29
30         gnome2_src_prepare
31 }
32
33 src_configure() {
34         gnome2_src_configure --disable-static
35 }
36
37 src_install() {
38         DOCS="AUTHORS ChangeLog NEWS README* docs/*.txt"
39         gnome2_src_install
40
41         if use examples; then
42                 cd "${S}"/examples
43                 insinto /usr/share/doc/${PF}/examples
44                 doins *.c *.h *.lwo README
45         fi
46 }