sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / www-misc / wsmake / wsmake-0.6.4.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Website pre-processor features tag substitution and page ordering"
7 HOMEPAGE="https://sourceforge.net/projects/wsmake/"
8 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
9
10 LICENSE="GPL-2+ Artistic"
11 SLOT="0"
12 KEYWORDS="x86"
13 IUSE="examples"
14
15 PATCHES=(
16         "${FILESDIR}"/${P}-bv.diff
17         "${FILESDIR}"/${P}-gcc43.patch  # 251745
18         "${FILESDIR}"/${P}-fix-const-va_list.patch
19 )
20
21 src_unpack() {
22         default
23
24         cd "${S}"/doc || die
25         tar -cf examples.tar examples || die
26 }
27
28 src_install() {
29         default
30         dodoc doc/manual.txt
31
32         if use examples; then
33                 rm -r doc/examples/CVS || die
34                 dodoc -r doc/examples
35                 docompress -x /usr/share/doc/${PF}/examples
36         fi
37 }