*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / www-client / ripe-atlas-cousteau / ripe-atlas-cousteau-1.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 MY_PN=${PN//-/.}
11 DESCRIPTION="A Python wrapper around the RIPE Atlas API"
12 HOMEPAGE="https://atlas.ripe.net/"
13 SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.cousteau/ripe.atlas.cousteau-${PV}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="amd64 x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 S="${WORKDIR}/${MY_PN}-${PVR}"
22
23 DOCS=( CHANGES.rst README.rst )
24
25 RDEPEND="
26         >=dev-python/socketio-client-0.6.5[${PYTHON_USEDEP}]
27         >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
28         dev-python/python-dateutil[${PYTHON_USEDEP}]"
29 DEPEND="
30         dev-python/setuptools[${PYTHON_USEDEP}]
31         test? (
32                 ${RDEPEND}
33                 dev-python/nose[${PYTHON_USEDEP}]
34                 dev-python/jsonschema[${PYTHON_USEDEP}]
35                 $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
36
37 python_test() {
38         nosetests --verbose || die "Tests failed with ${EPYTHON}"
39 }