*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / www-apps / novnc / novnc-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
11 HOMEPAGE="https://kanaka.github.com/noVNC/"
12
13 if [[ ${PV} == 9999 ]] ; then
14         inherit git-r3
15         EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
16 else
17         SRC_URI="https://github.com/kanaka/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
18         KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
19 fi
20
21 LICENSE="LGPL-3"
22 SLOT="0"
23 IUSE=""
24
25 DEPEND=""
26 RDEPEND="${DEPEND}
27         dev-python/websockify[${PYTHON_USEDEP}]
28         dev-python/numpy[${PYTHON_USEDEP}]"
29
30 python_compile() {
31         echo
32 }
33
34 src_install() {
35         exeinto /usr/share/novnc/utils
36         for f in utils/*; do
37                 [[ ! f = utils/README.md ]] && doexe $f
38         done
39
40         dodoc README.md LICENSE.txt
41
42         insinto /usr/share/novnc
43         doins -r vnc.html vnc_lite.html app/ core/ vendor/
44         dosym /usr/share/novnc/vnc_lite.html /usr/share/novnc/vnc_auto.html  # for compat
45 }