475a89beac0135d3256473d67fffe8545c83327f
[gentoo.git] / www-apps / cvsweb / cvsweb-1.112.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 DESCRIPTION="WWW interface to a CVS tree"
5 HOMEPAGE="http://www.freebsd.org/projects/cvsweb.html"
6 SRC_URI="mirror://gentoo/${P}.tar.gz"
7
8 LICENSE="BSD"
9 SLOT="0"
10 KEYWORDS="x86 sparc ~ppc"
11 IUSE=""
12
13 RDEPEND=">=dev-lang/perl-5
14         >=dev-vcs/rcs-5.7"
15
16 S="${WORKDIR}/cvsweb"
17
18 src_unpack() {
19         unpack ${P}.tar.gz
20         cd "${S}"
21         local x
22         for x in cvsweb.cgi cvsweb.conf
23         do
24                 cp ${x} ${x}.orig
25                 sed -e "s:/usr/local/web/apache/conf/:/etc/apache/conf/:g" ${x}.orig > ${x}
26         done
27 }
28
29 src_install() {
30         insinto /etc/apache/conf
31         doins cvsweb.conf
32         insinto /home/httpd/cgi-bin
33         insopts -m755
34         doins cvsweb.cgi
35         dodoc README TODO
36 }