8f4a1088b8a397a7b75d7e606cd3f31d90c257a0
[gentoo.git] / sys-process / numad / numad-0.5-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit linux-info toolchain-funcs eutils
7
8 if [[ ${PV} == "9999" ]]; then
9         EGIT_REPO_URI="https://pagure.io/numad.git"
10         inherit git-r3
11 else
12         HASH="334278ff3d774d105939743436d7378a189e8693"
13         SRC_URI="mirror://gentoo/numad-0.5-${HASH:0:7}.tar.bz2"
14         KEYWORDS="~amd64 -arm ~arm64 -s390 ~x86"
15         S="${WORKDIR}/${PN}-${HASH:0:7}"
16 fi
17
18 DESCRIPTION="The NUMA daemon that manages application locality"
19 HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
20
21 LICENSE="LGPL-2.1"
22 SLOT="0"
23 IUSE=""
24
25 CONFIG_CHECK="~NUMA ~CPUSETS"
26
27 src_prepare() {
28         epatch "${FILESDIR}"/0001-Fix-man-page-directory-creation.patch
29         epatch "${FILESDIR}"/${PN}-0.5-ldlibs.patch #505760
30         tc-export CC
31 }
32
33 src_compile() {
34         emake CFLAGS="${CFLAGS} -std=gnu99"
35 }
36
37 src_install() {
38         emake prefix="${ED}/usr" install
39 }