sys-process/gnome-usage: amd64 stable wrt bug #706524
[gentoo.git] / sys-process / gnome-usage / gnome-usage-3.32.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5 VALA_MIN_API_VERSION="0.36"
6 VALA_USE_DEPEND="vapigen"
7
8 inherit gnome.org gnome2-utils meson vala xdg
9
10 DESCRIPTION="A nice way to view information about use of system resources."
11 HOMEPAGE="https://wiki.gnome.org/Apps/Usage"
12
13 LICENSE="GPL-3+"
14 SLOT="0"
15 IUSE=""
16 KEYWORDS="amd64"
17
18 RDEPEND="
19         >=dev-libs/glib-2.38:2
20         >=x11-libs/gtk+-3.20.10:3
21         >=dev-libs/libdazzle-3.30
22         >=gnome-base/libgtop-2.34.0:2
23 "
24
25 DEPEND="${RDEPEND}
26         ${vala_depend}
27         >=sys-devel/gettext-0.19.8
28 "
29
30 src_prepare() {
31         vala_src_prepare
32         default
33 }
34
35 src_configure() {
36         meson_src_configure
37 }
38
39 pkg_postinst() {
40         xdg_pkg_postinst
41         gnome2_schemas_update
42 }
43
44 pkg_postrm() {
45         xdg_pkg_postrm
46         gnome2_schemas_update
47 }