dev-python/zc-lockfile: keyworded 2.0 for ia64, bug #717946
[gentoo.git] / sys-fs / aufs-util / aufs-util-4.14_p20190603.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit eutils flag-o-matic linux-info multilib toolchain-funcs
7
8 DESCRIPTION="Utilities are always necessary for aufs"
9 HOMEPAGE="http://aufs.sourceforge.net/"
10 SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
11 # git archive -v --prefix=${P}/ --remote=git://git.code.sf.net/p/aufs/aufs-util aufs4.14 -o ${P}.tar
12 # xz -ve9 *.tar
13
14 SLOT="0"
15 LICENSE="GPL-2"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 RDEPEND="
20         !sys-fs/aufs2
21         !<sys-fs/aufs3-3_p20130318"
22 DEPEND="${RDEPEND}
23         ~sys-fs/aufs-headers-${PV}"
24
25 src_prepare() {
26         sed \
27                 -e "/LDFLAGS += -static -s/d" \
28                 -e "/CFLAGS/s:-O::g" \
29                 -e "s:/usr/lib:/usr/$(get_libdir):g" \
30                 -i Makefile || die
31
32         sed \
33                 -e '/LDFLAGS/s: -s::g' \
34                 -e "s:m 644 -s:m 644:g" \
35                 -e "s:/usr/lib:/usr/$(get_libdir):g" \
36                 -i libau/Makefile || die
37
38         sed \
39                 -e '/LDFLAGS/s: -s::g' \
40                 -e '/LDLIBS/s:-lrt::g' \
41                 -e '/LDLIBS/s:$: -lrt:g' \
42                 -i fhsm/Makefile || die
43
44         tc-export CC AR
45         export HOSTCC=$(tc-getCC)
46         export STRIP=true
47         default
48 }