*/*: Switch proxy-maint to cmake.eclass
[gentoo.git] / sys-apps / thunderbolt-software-user-space / thunderbolt-software-user-space-0.9.3-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake linux-info
7
8 DESCRIPTION="Thunderbolt(TM) user-space components"
9 HOMEPAGE="https://github.com/intel/thunderbolt-software-user-space"
10 SRC_URI="https://github.com/intel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
11         https://dev.gentoo.org/~asturm/distfiles/${P}-tbtadm.1.tar.xz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE=""
17
18 # man needs app-text/txt2tags which is dormant upstream, so it is shipped pregenerated
19 DEPEND="dev-libs/boost:="
20 RDEPEND="${DEPEND}"
21
22 PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
23
24 pkg_pretend() {
25         CONFIG_CHECK="THUNDERBOLT"
26         ERROR_THUNDERBOLT="This program talks to the thunderbolt kernel driver, so please enable it."
27         CONFIG_CHECK="HOTPLUG_PCI"
28         ERROR_HOTPLUG_PCI="Thunderbolt needs pci hotplug support, so please enable it."
29         check_extra_config
30 }
31
32 src_prepare() {
33         cmake_src_prepare
34         cmake_comment_add_subdirectory docs
35 }
36
37 src_install() {
38         cmake_src_install
39         doman tbtadm.1
40 }