dev-python/zc-lockfile: keyworded 2.0 for ia64, bug #717946
[gentoo.git] / sys-apps / prctl / prctl-1.6-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools toolchain-funcs
7
8 DESCRIPTION="Tool to query and modify process behavior"
9 HOMEPAGE="https://sourceforge.net/projects/prctl/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
15 IUSE=""
16
17 RDEPEND=""
18 DEPEND=""
19
20 PATCHES=(
21         "${FILESDIR}"/${P}-no-implicits.patch
22 )
23
24 src_prepare() {
25         default
26
27         cp "${FILESDIR}"/{Makefile.am,configure.ac} ./ || die
28         eautoreconf
29 }