sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / sys-apps / paxctld / paxctld-1.2.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit systemd
7
8 DESCRIPTION="PaX flags maintenance daemon"
9 HOMEPAGE="https://www.grsecurity.net/"
10 SRC_URI="https://www.grsecurity.net/${PN}/${PN}_${PV}.orig.tar.gz
11         https://dev.gentoo.org/~blueness/hardened-sources/${PN}/${PN}_${PV}.orig.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
16 IUSE="pam"
17
18 RDEPEND=""
19 DEPEND=""
20
21 src_prepare() {
22         # Respect Gentoo flags and don't strip
23         sed -i \
24                 -e '/^CC/d' \
25                 -e '/^CFLAGS/d' \
26                 -e '/^LDFLAGS/d' \
27                 -e '/STRIP/d' \
28                 Makefile
29
30         eapply_user
31 }
32
33 src_install() {
34         default
35
36         systemd_dounit "${S}"/rpm/${PN}.service
37 }