396d4691041e1810a3ace6894e75b4ce28723548
[gentoo.git] / sys-apps / modutils / modutils-2.4.27-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Standard kernel module utilities for linux-2.4 and older"
7 HOMEPAGE="https://www.kernel.org/pub/linux/utils/kernel/modutils/"
8 SRC_URI="https://www.kernel.org/pub/linux/utils/kernel/${PN}/v2.4/${P}.tar.bz2"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 arm hppa ~ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86"
13
14 RDEPEND="!sys-apps/module-init-tools
15         !sys-apps/kmod"
16
17 PATCHES=(
18         "${FILESDIR}"/${P}-gcc.patch
19         "${FILESDIR}"/${P}-flex.patch
20         "${FILESDIR}"/${P}-no-nested-function.patch
21 )
22
23 src_configure() {
24         econf \
25                 --prefix=/ \
26                 --disable-strip \
27                 --enable-insmod-static \
28                 --disable-zlib
29 }
30
31 src_install() {
32         einstall prefix="${D}"
33         rm -r "${ED}"/usr/share/man/man2 || die
34         dodoc CREDITS ChangeLog NEWS README TODO
35 }