29ff57d6d8fb9d1da35e332d002a3e6711f0c7cd
[gentoo.git] / sys-apps / man-pages / man-pages-4.16.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 GENTOO_PATCH=2
7
8 DESCRIPTION="A somewhat comprehensive collection of Linux man pages"
9 HOMEPAGE="https://www.kernel.org/doc/man-pages/"
10 SRC_URI="mirror://kernel/linux/docs/man-pages/Archive/${P}.tar.xz
11         mirror://kernel/linux/docs/man-pages/${P}.tar.xz
12         mirror://gentoo/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2
13         https://dev.gentoo.org/~cardoe/files/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2"
14
15 LICENSE="man-pages GPL-2+ BSD"
16 SLOT="0"
17 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
18 IUSE_L10N=" da de fr it ja nl pl ru zh-CN"
19 IUSE="nls ${IUSE_L10N// / l10n_}"
20 RESTRICT="binchecks"
21
22 # Block packages that used to install colliding man pages #341953 #548900 #612640 #617462
23 RDEPEND="virtual/man
24         !<sys-apps/keyutils-1.5.9-r4
25         !<sys-apps/attr-2.4.47-r2
26         !<dev-libs/libaio-0.3.109-r2
27         !<dev-libs/libbsd-0.8.3-r1"
28 PDEPEND="nls? (
29         l10n_da? ( app-i18n/man-pages-da )
30         l10n_de? ( app-i18n/man-pages-de )
31         l10n_fr? ( app-i18n/man-pages-fr )
32         l10n_it? ( app-i18n/man-pages-it )
33         l10n_ja? ( app-i18n/man-pages-ja )
34         l10n_nl? ( app-i18n/man-pages-nl )
35         l10n_pl? ( app-i18n/man-pages-pl )
36         l10n_ru? ( app-i18n/man-pages-ru )
37         l10n_zh-CN? ( app-i18n/man-pages-zh_CN )
38         )
39         sys-apps/man-pages-posix"
40
41 src_configure() { :; }
42
43 src_compile() { :; }
44
45 src_install() {
46         emake install prefix="${EPREFIX}/usr" DESTDIR="${D}"
47         dodoc man-pages-*.Announce README Changes*
48
49         # Override with Gentoo specific or additional Gentoo pages
50         cd "${WORKDIR}"/man-pages-gentoo || die
51         doman */*
52         dodoc README.Gentoo
53 }