*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / sys-apps / kcheck / kcheck-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_6 )
6
7 inherit distutils-r1
8
9 if [[ ${PV} == 9999 ]]; then
10         EGIT_REPO_URI="https://github.com/wraeth/kcheck"
11         inherit git-r3
12 else
13         SRC_URI="https://github.com/wraeth/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
14         KEYWORDS="~amd64 ~x86"
15 fi
16
17 DESCRIPTION="Record and check required kernel symbols are set"
18 HOMEPAGE="https://github.com/wraeth/kcheck"
19
20 LICENSE="MIT"
21 SLOT="0"
22
23 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
24 RDEPEND="dev-python/configargparse[${PYTHON_USEDEP}]"
25
26 src_install() {
27         distutils-r1_src_install
28         mkdir "${D}"etc || die
29         mv -v "${D}"{usr/,}etc/kcheck.conf || die
30 }