Drop arm-linux keyword from tree.
[gentoo.git] / sys-apps / debianutils / debianutils-4.8.3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit flag-o-matic
7
8 DESCRIPTION="A selection of tools from Debian"
9 HOMEPAGE="https://packages.qa.debian.org/d/debianutils.html"
10 SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
11
12 LICENSE="BSD GPL-2 SMAIL"
13 SLOT="0"
14 KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
15 IUSE="kernel_linux static"
16
17 PATCHES=( "${FILESDIR}"/${PN}-3.4.2-no-bs-namespace.patch )
18
19 S="${WORKDIR}/${PN}"
20
21 src_configure() {
22         use static && append-ldflags -static
23         default
24 }
25
26 src_install() {
27         into /
28         dobin tempfile run-parts
29         if use kernel_linux ; then
30                 dosbin installkernel
31         fi
32
33         into /usr
34         dosbin savelog
35
36         doman tempfile.1 run-parts.8 savelog.8
37         use kernel_linux && doman installkernel.8
38         cd debian || die
39         dodoc changelog control
40         keepdir /etc/kernel/postinst.d
41 }