*/*: Bump copyright on files touched this year
[gentoo.git] / sys-apps / daisydog / daisydog-2014.05.30.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit toolchain-funcs flag-o-matic
7
8 GIT_SHA1="3182aa85c087446e4358370549adc45db21ec124"
9 MY_P="${PN}-${GIT_SHA1}"
10
11 DESCRIPTION="A very simple /dev/watchdog daemon"
12 HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/daisydog/+/master"
13 SRC_URI="mirror://gentoo/${MY_P}.tar.gz
14         https://chromium.googlesource.com/chromiumos/third_party/daisydog/+archive/${GIT_SHA1}.tar.gz -> ${MY_P}.tar.gz"
15
16 LICENSE="GPL-2+"
17 SLOT="0"
18 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
19 IUSE="static"
20
21 S=${WORKDIR}
22
23 src_configure() {
24         tc-export CC
25         use static && append-ldflags -static
26 }
27
28 src_install() {
29         dobin daisydog
30         dodoc README.chromiumos
31
32         newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
33         newinitd "${FILESDIR}"/${PN}.init.d ${PN}
34 }