*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / sci-libs / pyshp / pyshp-1.2.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 PYTHON_COMPAT=( python{2_7,3_6} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
10 HOMEPAGE="https://pypi.org/project/pyshp/"
11
12 if [[ ${PV} == "9999" ]] ; then
13         SRC_URI=""
14         ESVN_REPO_URI="https://${PN}.googlecode.com/svn/trunk"
15         inherit subversion
16 else
17         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
18         KEYWORDS="~amd64 ~x86"
19 fi
20
21 LICENSE="MIT"
22 SLOT="0"
23 IUSE=""
24
25 RDEPEND=""
26 DEPEND="${RDEPEND}
27         dev-python/setuptools[${PYTHON_USEDEP}]"