*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / sci-libs / Fiona / Fiona-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1 git-r3
9
10 DESCRIPTION="OGR's neat, nimble, no-nonsense API"
11 HOMEPAGE="https://pypi.org/project/Fiona/"
12 SRC_URI=""
13 EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND="
22         >=sci-libs/gdal-1.8
23         dev-python/click[${PYTHON_USEDEP}]"
24 DEPEND="${RDEPEND}
25         dev-python/setuptools[${PYTHON_USEDEP}]
26         dev-python/six[${PYTHON_USEDEP}]
27         test? (
28                 dev-python/nose[${PYTHON_USEDEP}]
29                 dev-python/pytest[${PYTHON_USEDEP}]
30         )"
31
32 PATCHES=( "${FILESDIR}"/scriptname.patch )
33
34 python_test() {
35         esetup.py test
36 }