*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / sci-geosciences / gpxpy / gpxpy-0.8.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1 vcs-snapshot
9
10 DESCRIPTION="python GPX parser"
11 HOMEPAGE="https://github.com/tkrajina/gpxpy"
12 SRC_URI="https://github.com/tkrajina/${PN}/tarball/85c3477b -> ${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE=""
18
19 DEPEND=""
20 RDEPEND=""
21
22 DOCS=( NOTICE.txt README.md )
23
24 python_test() {
25         ${PYTHON} -m unittest test
26 }