sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / sci-chemistry / dssp / dssp-2.2.1-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="The protein secondary structure standard"
9 HOMEPAGE="http://swift.cmbi.ru.nl/gv/dssp/"
10 SRC_URI="ftp://ftp.cmbi.ru.nl/pub/molbio/software/dssp-2/${P}.tgz"
11
12 LICENSE="Boost-1.0"
13 SLOT="0"
14 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
15 IUSE=""
16
17 RDEPEND="dev-libs/boost:=[threads]"
18 DEPEND="${RDEPEND}"
19
20 PATCHES=(
21         "${FILESDIR}"/${PN}-2.1.0-gentoo.patch
22         "${FILESDIR}"/${PN}-2.2.1-boost-1.65-tr1-removal.patch
23 )
24
25 src_configure() {
26         tc-export CXX
27
28         cat >> make.config <<- EOF || die
29                 BOOST_LIB_SUFFIX = -mt
30                 BOOST_LIB_DIR = "${EPREFIX}/usr/$(get_libdir)"
31                 BOOST_INC_DIR = "${EPREFIX}/usr/include"
32         EOF
33 }
34
35 src_install() {
36         dobin mkdssp
37         dosym mkdssp /usr/bin/dssp
38         doman doc/mkdssp.1
39         dodoc README.txt changelog
40
41         cat >> "${T}"/30-${PN} <<- EOF || die
42                 DSSP="${EPREFIX}"/usr/bin/${PN}
43         EOF
44         doenvd "${T}"/30-${PN}
45 }