*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / sci-biology / bioperl-network / bioperl-network-1.6.9.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 BIOPERL_RELEASE=1.6.9
7
8 MY_PN=BioPerl-Network
9 MODULE_AUTHOR=CJFIELDS
10 MODULE_VERSION=1.006900
11 inherit perl-module
12
13 DESCRIPTION="Perl tools for bioinformatics - Analysis of protein-protein interaction networks"
14 HOMEPAGE="http://www.bioperl.org/"
15
16 SLOT="0"
17 KEYWORDS="amd64 x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20 SRC_TEST="do"
21
22 CDEPEND=">=sci-biology/bioperl-${PV}
23         >=dev-perl/Graph-0.86"
24 DEPEND="dev-perl/Module-Build
25         ${CDEPEND}"
26 RDEPEND="${CDEPEND}"
27
28 src_install() {
29         mydoc="AUTHORS BUGS"
30         perl-module_src_install
31 }