*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / net-wireless / soapyremote / soapyremote-0.5.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit cmake-utils
9
10 DESCRIPTION="Soapy SDR remote module"
11 HOMEPAGE="https://github.com/pothosware/SoapyRemote"
12
13 if [ "${PV}" = "9999" ]; then
14         EGIT_REPO_URI="https://github.com/pothosware/SoapyRemote.git"
15         EGIT_CLONE_TYPE="shallow"
16         KEYWORDS=""
17         inherit git-r3
18 else
19         KEYWORDS="~amd64 ~x86"
20         SRC_URI="https://github.com/pothosware/SoapyRemote/archive/soapy-remote-${PV}.tar.gz -> ${P}.tar.gz"
21         S="${WORKDIR}"/SoapyRemote-soapy-remote-"${PV}"
22 fi
23
24 LICENSE="Boost-1.0"
25 SLOT="0"
26
27 IUSE=""
28 REQUIRED_USE=""
29
30 RDEPEND="net-wireless/soapysdr
31                 net-dns/avahi"
32 DEPEND="${RDEPEND}"