bd1271c894bc96ae21d63f4d803a9b65e0e4ce0a
[gentoo.git] / net-p2p / createtorrent / createtorrent-1.1.4.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 inherit autotools eutils
5
6 DESCRIPTION="Create BitTorrent files easily"
7 HOMEPAGE="http://www.createtorrent.com/"
8 SRC_URI="http://www.createtorrent.com/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
13 IUSE=""
14
15 RDEPEND="dev-libs/openssl"
16 DEPEND="${RDEPEND}"
17
18 src_unpack() {
19         unpack ${A}
20         cd "${S}"
21         sed -i "s:[[]ssl[]]:[crypto]:" configure.in || die "sed failed..."
22         eautoreconf
23 }
24
25 src_install() {
26         emake DESTDIR="${D}" install || die "emake install failed."
27         dodoc AUTHORS ChangeLog NEWS README
28 }