*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / net-misc / s3cmd / s3cmd-2.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6}  )
7 PYTHON_REQ_USE="xml"
8
9 inherit distutils-r1
10
11 DESCRIPTION="Command line client for Amazon S3"
12 HOMEPAGE="https://s3tools.org/s3cmd"
13 SRC_URI="mirror://sourceforge/s3tools/${P/_/-}.tar.gz"
14 LICENSE="GPL-2"
15 SLOT="0"
16
17 KEYWORDS="amd64 ia64 x86 ~x64-macos"
18 IUSE=""
19
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
21 RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
22         dev-python/python-magic[${PYTHON_USEDEP}]"
23
24 S="$WORKDIR/${P/_/-}"