dev-python/zc-lockfile: keyworded 2.0 for ia64, bug #717946
[gentoo.git] / net-misc / liveice / liveice-2000530-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Live Source Client For IceCast"
9 HOMEPAGE="http://star.arm.ac.uk/~spm/software/liveice.html"
10 SRC_URI="mirror://gentoo/${P}.tar.gz"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~amd64 x86"
15
16 RDEPEND="media-sound/lame
17         media-sound/mpg123"
18 DEPEND=""
19
20 S=${WORKDIR}/${PN}
21
22 src_prepare() {
23         default
24         # cannot use LDFLAGS directly as the Makefile uses it for LIBS
25         sed -i Makefile.in \
26                 -e 's|-o liveice|$(LLFLAGS) &|' \
27                 || die "sed Makefile.in"
28         tc-export CC
29 }
30
31 src_compile() {
32         emake LLFLAGS="${LDFLAGS}"
33 }
34 src_install() {
35         dobin liveice
36         dodoc liveice.cfg README.liveice README.quickstart README_new_mixer.txt Changes.txt
37 }