f2fd83afc2811ce3163799b17d25744c36e811d9
[gentoo.git] / net-misc / gns3-gui / gns3-gui-2.1.21.ebuild
1 # Copyright 1999-2019 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{5,6} )
7
8 inherit distutils-r1 desktop
9
10 DESCRIPTION="Graphical Network Simulator"
11 HOMEPAGE="http://www.gns3.net/"
12 SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17
18 #net-misc/gns3-server version should always match gns3-gui version
19
20 RDEPEND="
21         >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
22         >=dev-python/raven-5.23.0[${PYTHON_USEDEP}]
23         >=dev-python/psutil-2.2.1[${PYTHON_USEDEP}]
24         ~net-misc/gns3-server-${PV}[${PYTHON_USEDEP}]
25         dev-python/PyQt5[gui,network,svg,websockets,widgets,${PYTHON_USEDEP}]
26 "
27 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
28
29 python_install_all() {
30         distutils-r1_python_install_all
31
32         doicon "resources/images/gns3.ico"
33         make_desktop_entry "gns3" "GNS3" "gns3.ico" "Utility"
34 }