83a9098db3da5508a47a4d6ca437a8f52d70a012
[gentoo.git] / net-mail / isync / isync-1.3.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="MailDir mailbox synchronizer"
7 HOMEPAGE="http://isync.sourceforge.net/"
8 LICENSE="GPL-2"
9 SLOT="0"
10
11 if [[ ${PV} == 9999 ]]; then
12         EGIT_REPO_URI="https://git.code.sf.net/p/${PN}/${PN}"
13         inherit git-r3 autotools
14 else
15         SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
16         KEYWORDS="amd64 ~arm ~ppc x86"
17 fi
18
19 IUSE="libressl sasl ssl zlib"
20
21 RDEPEND="
22         >=sys-libs/db-4.2:=
23         sasl?   ( dev-libs/cyrus-sasl )
24         ssl?    (
25                         !libressl?      ( >=dev-libs/openssl-0.9.6:0= )
26                         libressl?       ( dev-libs/libressl:0= )
27                 )
28         zlib?   ( sys-libs/zlib:0= )
29 "
30 DEPEND="${RDEPEND}
31         dev-lang/perl
32 "
33
34 src_prepare() {
35         default
36         [[ ${PV} == 9999 ]] && eautoreconf
37 }
38
39 src_configure() {
40         econf \
41                 $(use_with ssl) \
42                 $(use_with sasl) \
43                 $(use_with zlib)
44 }