sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / net-libs / telepathy-farstream / telepathy-farstream-0.6.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 GCONF_DEBUG="no"
6
7 inherit gnome2
8
9 DESCRIPTION="Telepathy client library that uses Farstream to handle Call channels"
10 HOMEPAGE="https://telepathy.freedesktop.org/"
11 SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0/3"
15 KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc ~ppc64 x86"
16 IUSE="examples +introspection"
17
18 RDEPEND="
19         >=dev-libs/glib-2.32:2
20         >=sys-apps/dbus-0.60
21         >=dev-libs/dbus-glib-0.60
22         media-libs/gstreamer:1.0[introspection?]
23         >=net-libs/telepathy-glib-0.21[introspection?]
24         net-libs/farstream:0.2=[introspection?]
25         introspection? ( >=dev-libs/gobject-introspection-1.30 )
26 "
27 DEPEND="${RDEPEND}
28         >=dev-util/gtk-doc-am-1.17
29         virtual/pkgconfig
30 "
31
32 src_configure() {
33         gnome2_src_configure \
34                 --disable-static \
35                 --disable-Werror \
36                 $(use_enable introspection)
37 }
38
39 src_install() {
40         gnome2_src_install
41
42         if use examples; then
43                 insinto /usr/share/doc/${PF}/examples
44                 doins examples/*.c
45                 insinto /usr/share/doc/${PF}/examples/python
46                 doins examples/python/*.py
47         fi
48 }