a1f53b70ec3743828f504f7a81f1fbb922d04897
[gentoo.git] / net-libs / rpcsvc-proto / rpcsvc-proto-1.4-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 DESCRIPTION="rpcsvc protocol definitions from glibc"
9 HOMEPAGE="https://github.com/thkukuk/rpcsvc-proto"
10 SRC_URI="https://github.com/thkukuk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 SLOT="0"
13 LICENSE="LGPL-2.1+ BSD"
14 KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 ~sh sparc x86"
15 IUSE=""
16
17 # sys-devel/gettext is only for libintl detection macros.
18 DEPEND="sys-devel/gettext"
19 RDEPEND="
20         !<sys-libs/glibc-2.26
21         virtual/libintl
22 "
23
24 PATCHES=("${FILESDIR}"/${P}-external-libintl.patch)
25
26 src_prepare(){
27         default
28         eautoreconf
29 }
30
31 src_install(){
32         default
33
34         # provided by sys-fs/quota[rpc]
35         rm "${ED}"/usr/include/rpcsvc/rquota.{x,h} || die
36 }