*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / net-libs / ripe-atlas-sagan / ripe-atlas-sagan-1.1.11.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python{3_5,3_6} )
7
8 inherit distutils-r1
9
10 MY_PN=${PN//-/.}
11 DESCRIPTION="A parsing library for RIPE Atlas result strings"
12 HOMEPAGE="https://atlas.ripe.net/"
13 SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.sagan/ripe.atlas.sagan-${PV}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="amd64 x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20 DOCS=( CHANGES.rst README.rst )
21
22 S="${WORKDIR}/${MY_PN}-${PVR}"
23
24 RDEPEND="
25         dev-python/python-dateutil[${PYTHON_USEDEP}]
26         dev-python/pytz[${PYTHON_USEDEP}]
27         dev-python/pyopenssl[${PYTHON_USEDEP}]
28         dev-python/ujson[${PYTHON_USEDEP}]"
29 DEPEND="
30         dev-python/setuptools[${PYTHON_USEDEP}]
31         test? (
32                 ${RDEPEND}
33                 dev-python/nose[${PYTHON_USEDEP}] )"
34
35 python_test() {
36         nosetests --verbose || die "Tests failed with ${EPYTHON}"
37 }