*/*: Drop stable ia64 keywords
[gentoo.git] / net-libs / libnetfilter_conntrack / libnetfilter_conntrack-1.0.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools linux-info
6
7 DESCRIPTION="programming interface (API) to the in-kernel connection tracking state table"
8 HOMEPAGE="https://www.netfilter.org/projects/libnetfilter_conntrack/"
9 SRC_URI="https://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 s390 sparc x86"
14 IUSE="static-libs"
15
16 RDEPEND="
17         >=net-libs/libmnl-1.0.3
18         >=net-libs/libnfnetlink-1.0.0
19 "
20 DEPEND="
21         ${RDEPEND}
22         virtual/pkgconfig
23 "
24
25 DOCS=( README )
26
27 pkg_setup() {
28         linux-info_pkg_setup
29
30         if kernel_is lt 2 6 18 ; then
31                 die "${PN} requires at least 2.6.18 kernel version"
32         fi
33
34         #netfilter core team has changed some option names with kernel 2.6.20
35         if kernel_is lt 2 6 20 ; then
36                 CONFIG_CHECK="~IP_NF_CONNTRACK_NETLINK"
37         else
38                 CONFIG_CHECK="~NF_CT_NETLINK"
39         fi
40
41         check_extra_config
42 }