sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / net-libs / libmbim / libmbim-1.16.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit multilib
7
8 DESCRIPTION="Mobile Broadband Interface Model (MBIM) modem protocol helper library"
9 HOMEPAGE="https://cgit.freedesktop.org/libmbim/"
10 SRC_URI="https://www.freedesktop.org/software/libmbim/${P}.tar.xz"
11
12 LICENSE="LGPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 ~mips ppc ppc64 x86"
15 IUSE="static-libs udev"
16
17 RDEPEND=">=dev-libs/glib-2.32:2
18         udev? ( dev-libs/libgudev:= )"
19 DEPEND="${RDEPEND}
20         dev-util/glib-utils
21         dev-util/gtk-doc-am
22         virtual/pkgconfig"
23
24 src_configure() {
25         econf \
26                 --disable-more-warnings \
27                 --disable-gtk-doc \
28                 $(use_with udev) \
29                 $(use_enable static{-libs,})
30 }
31
32 src_install() {
33         default
34         use static-libs || rm -f "${ED}/usr/$(get_libdir)/${PN}-glib.la"
35 }