*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / net-im / skype-dbus-mock / skype-dbus-mock-0_pre20181011.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_6,3_7} )
7
8 inherit python-r1
9
10 GIT_COMMIT="3a9e2882ac5c0ad6be3c5cb5c7da008b4cfa51da"
11 DESCRIPTION="Mocked systemd dbus interface for skype 8.30+"
12 HOMEPAGE="https://github.com/maelnor/skype-dbus-mock"
13 SRC_URI="https://github.com/maelnor/${PN}/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 IUSE=""
19 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
20
21 DEPEND="${PYTHON_DEPS}"
22 RDEPEND="${DEPEND}
23         >=net-im/skypeforlinux-8.30
24         dev-python/dbus-python[${PYTHON_USEDEP}]
25         !sys-apps/systemd
26         !sys-auth/elogind"
27
28 S=${WORKDIR}/${PN}-${GIT_COMMIT}
29
30 src_install() {
31         newbin skype-dbus-mock.py skype-dbus-mock
32         insinto /usr/share/dbus-1/system-services
33         doins org.freedesktop.login1.service
34         insinto /usr/share/dbus-1/system.d
35         doins skype-dbus-mock.conf
36 }
37
38 pkg_postinst() {
39         ewarn "Restart dbus service to apply changes"
40 }