4f74bd138155d6e98bddd557f80b48f7d8606941
[gentoo.git] / net-firewall / fwanalog / fwanalog-0.6.4.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 DESCRIPTION="Script to parse firewall logs and analyze them with Analog"
5 HOMEPAGE="http://tud.at/programm/fwanalog/"
6 SRC_URI="http://tud.at/programm/fwanalog/${P}.tar.gz"
7
8 LICENSE="GPL-2"
9 SLOT="0"
10 KEYWORDS="~amd64 x86 ppc sparc"
11 IUSE=""
12
13 DEPEND="" # this is just a bash script
14 RDEPEND="app-shells/bash
15         sys-apps/grep
16         virtual/awk
17         sys-apps/sed
18         app-arch/gzip
19         sys-apps/diffutils
20         dev-lang/perl
21         >=app-admin/analog-5.31"
22
23 src_install() {
24         insinto /etc/fwanalog
25
26         insopts -m0700 ; doins fwanalog.sh
27
28         insopts -m0600
29         doins fwanalog-dom.tab fwanalog.lng services.conf
30         doins fwanalog.analog.conf fwanalog.analog.conf.local
31         newins fwanalog.opts.linux24 fwanalog.opts
32
33         dosed "s/\"zegrep\"/\"egrep\"/" /etc/fwanalog/fwanalog.opts
34
35         dodoc CONTRIBUTORS ChangeLog README
36         docinto support ; dodoc support/*
37         docinto langfiles ; dodoc langfiles/*
38 }