*/*: [QA] Remove redundant --disable-{dependency-tracking,silent-rules}
[gentoo.git] / net-dns / libidn2 / libidn2-2.1.1a-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit multilib-minimal
6
7 DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
8 HOMEPAGE="https://www.gnu.org/software/libidn/#libidn2 https://gitlab.com/libidn/libidn2"
9 SRC_URI="
10         mirror://gnu/libidn/${P}.tar.gz
11 "
12
13 LICENSE="GPL-2+ LGPL-3+"
14 SLOT="0/2"
15 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16 IUSE="static-libs"
17
18 RDEPEND="
19         dev-libs/libunistring[${MULTILIB_USEDEP}]
20 "
21 DEPEND="${RDEPEND}"
22 BDEPEND="
23         dev-lang/perl
24         sys-apps/help2man
25 "
26 S=${WORKDIR}/${P/a/}
27
28 src_prepare() {
29         default
30
31         if [[ ${CHOST} == *-darwin* ]] ; then
32                 # Darwin ar chokes when TMPDIR doesn't exist (as done for some
33                 # reason in the Makefile)
34                 sed -i -e '/^TMPDIR = /d' Makefile.in || die
35                 export TMPDIR="${T}"
36         fi
37
38         multilib_copy_sources
39 }
40
41 multilib_src_configure() {
42         econf \
43                 $(use_enable static-libs static) \
44                 --disable-doc \
45                 --disable-gcc-warnings \
46                 --disable-gtk-doc
47 }
48
49 multilib_src_install() {
50         default
51
52         find "${D}" -name '*.la' -delete || die
53 }