*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / net-dns / dnsviz / dnsviz-0.8.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7 inherit distutils-r1 eutils
8
9 DESCRIPTION="Tool suite for analysis and visualization of DNS and DNSSEC"
10 HOMEPAGE="https://dnsviz.net/"
11 SRC_URI="https://github.com/dnsviz/dnsviz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 SLOT="0"
14 LICENSE="GPL-2"
15 KEYWORDS="amd64 x86"
16 IUSE=""
17
18 DEPEND="
19         dev-python/dnspython[${PYTHON_USEDEP}]
20         dev-python/libnacl[${PYTHON_USEDEP}]
21         >=dev-python/m2crypto-0.31.0[${PYTHON_USEDEP}]
22         >=dev-python/pygraphviz-1.3.1[${PYTHON_USEDEP}]
23         dev-python/setuptools[${PYTHON_USEDEP}]"
24
25 RDEPEND="
26         ${DEPEND}"
27
28 python_prepare_all() {
29         # Fix the ebuild to use correct FHS/Gentoo policy paths for 0.8.2
30         sed -i "s*share/doc/dnsviz*share/doc/dnsviz-${PV}*g" "${S}"/setup.py || die
31
32         distutils-r1_python_prepare_all
33 }
34
35 pkg_postinst() {
36         elog "Support for extra feature can be get from:"
37         optfeature "Support for pre-deployment testing" net-dns/bind
38
39         # Warn about extra requirements for >=OpenSSL 1.1.0
40         if has_version '=dev-libs/openssl-1.1*'; then
41            echo
42            ewarn "With OpenSSL version 1.1.0 and later,the OpenSSL GOST Engine"
43            ewarn "is necessary to validate DNSSEC signatures with algorithm 12"
44            ewarn "(GOST R 34.10-2001) and digests of type 3 (GOST R 34.11-94)"
45            ewarn "OpenSSL GOST Engine can be get from --> dev-libs/gost-engine"
46         fi
47 }