net-dialup/picocom: amd64 stable wrt bug #689216
[gentoo.git] / net-dialup / picocom / picocom-3.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="minimal dumb-terminal emulation program"
9 HOMEPAGE="https://github.com/npat-efault/picocom"
10 SRC_URI="https://github.com/npat-efault/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
15 IUSE=""
16
17 src_compile() {
18         # CPPFLAGS is shared between CFLAGS and CXXFLAGS, but there is no
19         # C++ file, and the pre-processor is never called directly, this
20         # is easier than patching it out.
21         emake LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} ${CPPFLAGS} -Wall" \
22                 CC="$(tc-getCC)"
23 }
24
25 src_install() {
26         dobin picocom pc{asc,xm,ym,zm}
27         doman picocom.1
28         dodoc CHANGES.old CONTRIBUTORS README.md
29 }