*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / net-analyzer / pypacker / pypacker-4.8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7} )
6 inherit distutils-r1 vcs-snapshot
7
8 DESCRIPTION="Fast and simple packet creation and parsing library for Python"
9 HOMEPAGE="https://gitlab.com/mike01/pypacker"
10 SRC_URI="https://gitlab.com/mike01/pypacker/-/archive/v${PV}/pypacker-v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="examples"
16
17 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
18 DOCS=( AUTHORS CHANGES HACKING README.md )
19
20 python_test() {
21         "${EPYTHON}" tests/test_pypacker.py || die
22 }
23
24 python_install_all() {
25         distutils-r1_python_install_all
26         use examples && dodoc -r examples
27 }