*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / net-analyzer / pypacker / pypacker-4.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1 vcs-snapshot
9
10 DESCRIPTION="Fast and simple packet creation and parsing library for Python"
11 HOMEPAGE="https://gitlab.com/mike01/pypacker"
12 SRC_URI="https://gitlab.com/mike01/pypacker/-/archive/v${PV}/pypacker-v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="examples"
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20
21 DOCS=( AUTHORS CHANGES HACKING README.md )
22
23 python_test() {
24         "${PYTHON}" tests/test_pypacker.py || die
25 }
26
27 python_install_all() {
28         distutils-r1_python_install_all
29         use examples && dodoc -r examples
30 }