*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / net-analyzer / prelude-correlator / prelude-correlator-5.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit distutils-r1 systemd
9
10 DESCRIPTION="Real time correlator of events received by Prelude Manager"
11 HOMEPAGE="https://www.prelude-siem.org"
12 SRC_URI="https://www.prelude-siem.org/pkg/src/5.1.0/${P}.tar.gz"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17
18 RDEPEND=">=dev-libs/libprelude-5.1.0[python,${PYTHON_USEDEP}]
19         <dev-libs/libprelude-6[python,${PYTHON_USEDEP}]
20         dev-python/netaddr[${PYTHON_USEDEP}]"
21
22 src_install() {
23         distutils-r1_src_install
24
25         systemd_dounit "${FILESDIR}/${PN}.service"
26         systemd_newtmpfilesd "${FILESDIR}/${PN}.run" "${PN}.conf"
27
28         newinitd "${FILESDIR}/${PN}.initd" "${PN}"
29 }