*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / net-analyzer / 2ping / 2ping-4.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A bi-directional ping utility"
11 HOMEPAGE="https://www.finnie.org/software/2ping/"
12 SRC_URI="https://www.finnie.org/software/2ping/${P}.tar.gz"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
17 IUSE="server"
18
19 src_install() {
20         distutils-r1_src_install
21         doman doc/2ping.1
22         dodoc doc/{2ping-protocol-examples.py,2ping-protocol.md}
23         use server && {
24                 doinitd "${FILESDIR}"/2pingd
25                 newconfd "${FILESDIR}"/2pingd.conf 2pingd
26         }
27 }