83a3896bff56c504512fd055e67835603ba057f5
[gentoo.git] / media-sound / saydate / saydate-0.3.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 S=${WORKDIR}/${PN}
5 DESCRIPTION="A Linux shell program that talks the date and system uptime"
6 HOMEPAGE="http://unihedron.com/projects/saydate/saydate.php"
7 SRC_URI="http://unihedron.com/projects/saydate/${P}.tar.gz"
8 LICENSE="GPL-2"
9 SLOT="0"
10
11 KEYWORDS="amd64 ~ppc ppc64 sparc x86"
12
13 DEPEND="=sys-apps/sed-4*"
14 IUSE=""
15
16 # Don't leave this empty or it tries to install directly
17 # on livefs
18 src_compile() { :; }
19
20 src_install () {
21         insinto /usr/share/man/man1
22         doins "${S}"/man/saydate.1.gz "${S}"/man/au2raw.1.gz
23
24         dodir /usr/share/saydate
25         insinto /usr/share/saydate
26         doins "${S}"/data/*.raw
27
28         sed -i "s:/dev/audio:/dev/dsp:" "${S}"/saydate
29         sed -i "s:/dev/audio:/dev/dsp:" "${S}"/au2raw
30         sed -i "s:/dev/audio:/dev/dsp:" "${S}"/DESIGN
31         dodoc README TODO HISTORY DESIGN
32         dobin saydate au2raw || die "dobin failed"
33 }