*/*: Bump copyright on files touched this year
[gentoo.git] / media-plugins / kodi-pvr-vuplus / kodi-pvr-vuplus-3.28.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake kodi-addon
7
8 DESCRIPTION="Kodi's VuPlus client addon"
9 HOMEPAGE="https://github.com/kodi-pvr/pvr.vuplus"
10 SRC_URI=""
11
12 case ${PV} in
13 9999)
14         SRC_URI=""
15         EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.vuplus.git"
16         inherit git-r3
17         ;;
18 *)
19         CODENAME="Leia"
20         KEYWORDS="~amd64 ~x86"
21         SRC_URI="https://github.com/kodi-pvr/pvr.vuplus/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
22         S="${WORKDIR}/pvr.vuplus-${PV}-${CODENAME}"
23         ;;
24 esac
25
26 LICENSE="GPL-2"
27 SLOT="0"
28 IUSE=""
29
30 DEPEND="
31         =media-tv/kodi-18*
32         =media-libs/kodi-platform-18*
33         dev-libs/tinyxml
34         dev-cpp/nlohmann_json
35         "
36
37 RDEPEND="
38         ${DEPEND}
39         "
40
41 src_prepare(){
42         [ -d depends ] && rm -rf depends || die
43         cmake_src_prepare
44 }