sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / media-libs / libxspf / libxspf-1.2.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit xdg-utils
7
8 DESCRIPTION="Playlist handling library"
9 HOMEPAGE="http://libspiff.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/libspiff/${P}.tar.bz2"
11
12 LICENSE="BSD LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
15 IUSE="static-libs test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         >=dev-libs/expat-2
20         >=dev-libs/uriparser-0.7.5"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig
23         test? ( >=dev-util/cpptest-1.1 )"
24
25 DOCS=( AUTHORS ChangeLog NEWS README THANKS )
26
27 PATCHES=(
28         "${FILESDIR}"/${P}-gcc44.patch
29         "${FILESDIR}"/${P}-gcc47.patch
30 )
31
32 src_prepare() {
33         default
34         xdg_environment_reset
35
36         # do not install missing files
37         sed -e 's/gif,//' -i doc/Makefile* \
38                 -i bindings/c/doc/Makefile* || die "sed failed"
39 }
40
41 src_configure() {
42         econf \
43                 --disable-doc \
44                 $(use_enable static-libs static) \
45                 $(use_enable test)
46 }
47
48 src_install() {
49         default
50         find "${D}" -name '*.la' -delete || die
51 }