*/*: Bump copyright on files touched this year
[gentoo.git] / media-libs / libiec61883 / libiec61883-1.2.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools-multilib eutils unpacker autotools
7
8 DESCRIPTION="Library for capturing video (dv or mpeg2) over the IEEE 1394 bus"
9 HOMEPAGE="http://dennedy.org/cgi-bin/gitweb.cgi?p=dennedy.org/libiec61883.git"
10 SRC_URI="https://www.kernel.org/pub/linux/libs/ieee1394/${P}.tar.xz"
11
12 LICENSE="|| ( LGPL-2.1 GPL-2 )"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 ia64 ppc ppc64 sparc x86"
15 IUSE="examples static-libs"
16
17 RDEPEND=">=sys-libs/libraw1394-2.1.0-r1[${MULTILIB_USEDEP}]"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig"
20
21 src_prepare() {
22         if use examples; then
23                 sed -i -e "s:noinst_PROGRAMS.*:noinst_PROGRAMS = :g" \
24                 -e "s:in_PROGRAMS.*:in_PROGRAMS = plugreport plugctl test-amdtp test-dv test-mpeg2 test-plugs:g" \
25                 examples/Makefile.am || die "noinst patching failed"
26                 AUTOTOOLS_AUTORECONF="1"
27         fi
28         autotools-multilib_src_prepare
29 }