*/*: Bump copyright on files touched this year
[gentoo.git] / media-libs / libggi / libggi-2.2.2-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Provides an opaque interface to the display's acceleration function"
7 HOMEPAGE="https://ibiblio.org/ggicore/packages/libggi.html"
8 SRC_URI="mirror://sourceforge/ggi/${P}.src.tar.bz2"
9
10 LICENSE="MIT"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 ~sh sparc x86"
13 IUSE="3dfx aalib cpu_flags_x86_mmx debug fbcon svga vis X"
14
15 RDEPEND=">=media-libs/libgii-1.0.2
16         aalib? ( >=media-libs/aalib-1.2-r1 )
17         svga? ( >=media-libs/svgalib-1.4.2 )
18         X? (
19                 x11-libs/libXt
20                 x11-libs/libXxf86dga
21                 x11-libs/libXxf86vm
22         )"
23 DEPEND="${RDEPEND}
24         X? ( x11-base/xorg-proto )"
25
26 DOCS=( ChangeLog ChangeLog.1999 FAQ NEWS README )
27
28 src_configure() {
29         local myconf=""
30
31         use svga || myconf="${myconf} --disable-svga --disable-vgagl"
32
33         if use amd64 || use ppc64 || use ia64 ; then
34                 myconf="${myconf} --enable-64bitc"
35         else
36                 myconf="${myconf} --disable-64bitc"
37         fi
38
39         econf $(use_enable 3dfx glide) \
40                 $(use_enable aalib aa) \
41                 $(use_enable debug) \
42                 $(use_enable cpu_flags_x86_mmx mmx) \
43                 $(use_enable vis) \
44                 $(use_with X x) \
45                 $(use_enable X x) \
46                 $(use_enable fbcon fbdev) \
47                 --disable-directfb \
48                 --disable-static \
49                 ${myconf}
50 }
51
52 src_install(){
53         default
54
55         docinto txt
56         dodoc doc/*.txt
57
58         find "${D}" -name '*.la' -delete || die
59 }