sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / media-libs / libbdplus / libbdplus-0.1.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit autotools-multilib
6
7 if [[ ${PV} == 9999 ]] ; then
8         inherit git-r3
9         EGIT_REPO_URI="https://code.videolan.org/videolan/libbdplus.git"
10 else
11         SRC_URI="https://downloads.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
12         KEYWORDS="amd64 ppc ppc64 sparc x86"
13 fi
14
15 DESCRIPTION="Blu-ray library for BD+ decryption"
16 HOMEPAGE="https://www.videolan.org/developers/libbdplus.html"
17
18 LICENSE="LGPL-2.1"
19 SLOT="0"
20 IUSE="aacs static-libs"
21
22 RDEPEND="dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
23         dev-libs/libgpg-error[${MULTILIB_USEDEP}]
24         aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )"
25 DEPEND="${RDEPEND}"
26
27 DOCS="ChangeLog README.txt"
28
29 src_configure() {
30         local myeconfargs=(
31                 --disable-optimizations
32                 $(use_with aacs libaacs)
33         )
34         autotools-multilib_src_configure
35 }