dev-python/zc-lockfile: keyworded 2.0 for ia64, bug #717946
[gentoo.git] / media-libs / cimg / cimg-2.8.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="C++ template image processing toolkit"
7 HOMEPAGE="https://cimg.eu/ https://github.com/dtschump/CImg"
8 SRC_URI="https://github.com/dtschump/CImg/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="CeCILL-2 CeCILL-C"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="doc examples"
14
15 S=${WORKDIR}/CImg-v.${PV}
16
17 src_install() {
18         doheader CImg.h
19         dodoc README.txt
20
21         use doc && dodoc -r html
22         if use examples; then
23                 dodoc -r examples
24                 docompress -x /usr/share/doc/${PF}/examples
25         fi
26 }