Drop arm-linux keyword from tree.
[gentoo.git] / media-libs / babl / babl-0.1.44.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eutils
7
8 if [[ ${PV} == *9999* ]]; then
9         inherit autotools git-r3
10         EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/babl.git"
11         SRC_URI=""
12 else
13         SRC_URI="http://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
14         KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
15 fi
16
17 DESCRIPTION="A dynamic, any to any, pixel format conversion library"
18 HOMEPAGE="http://www.gegl.org/babl/"
19
20 LICENSE="LGPL-3"
21 SLOT="0"
22 IUSE="altivec cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_mmx cpu_flags_x86_f16c"
23
24 RDEPEND=""
25 DEPEND="${RDEPEND}
26         >=sys-devel/libtool-2.2
27         virtual/pkgconfig
28 "
29
30 src_prepare() {
31         default
32         [[ ${PV} == *9999* ]] && eautoreconf
33 }
34
35 src_configure() {
36         # Automagic rsvg support is just for website generation we do not call,
37         #     so we don't need to fix it
38         # w3m is used for dist target thus no issue for us that it is automagically
39         #     detected
40         econf \
41                 --disable-docs \
42                 --disable-static \
43                 --disable-maintainer-mode \
44                 $(use_enable altivec) \
45                 $(use_enable cpu_flags_x86_f16c f16c) \
46                 $(use_enable cpu_flags_x86_mmx mmx) \
47                 $(use_enable cpu_flags_x86_sse sse) \
48                 $(use_enable cpu_flags_x86_sse2 sse2) \
49                 $(use_enable cpu_flags_x86_sse4_1 sse4_1)
50 }
51
52 src_install() {
53         default
54         prune_libtool_files --all
55 }